Tuesday, September 14, 2010

OSPF Mock Lab - Another Challenge To Solve (Solution 1)

So after a little long I am back with Solution of OSPF mock lab challenge. But good part is that someone actually solved the puzzle and won the prize. 

Yup...Manish Salaria

Although his solution was different from mine and looks easier to configure, but if you will get into details about how packet is flowing between R2's loop-back and R6's loop-back then things might get little complicated to understand in first look.

Anyways here I am posting his solution, soon this week I'll post mine too. With his solution though I am not putting any explanation here but mine solution will be having detailed walk through.

I changed interface numbering a little bit as I tested this on different PC running Linux and different Set of IOS.  So you may want to adjust interface numbering under initial configuration I gave in first post.


Here is quick GNS topology I used: Click on Image for better view




So here we go: 


R1:
R1#sh ip int b | e una|do
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  123.123.123.1   YES manual up                    up     
FastEthernet1/0            14.14.14.1      YES manual up                  up     
Loopback0                  11.11.11.11     YES manual up                   up  



R1#sh run int s0/0
Building configuration...

Current configuration : 337 bytes
!
interface Serial0/0
 ip address 123.123.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 123.123.123.1 102
 frame-relay map ip 123.123.123.2 102 broadcast
 frame-relay map ip 123.123.123.3 103 broadcast
 no frame-relay inverse-arp
end


R1#sh run | s r o
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 14.14.14.1 0.0.0.0 area 1
 network 123.123.123.1 0.0.0.0 area 0


R1#sh ip ro | b ^G  
Gateway of last resort is 14.14.14.4 to network 0.0.0.0

     33.0.0.0/24 is subnetted, 1 subnets
O       33.33.33.0 [110/65] via 123.123.123.3, 02:39:10, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
O       22.22.22.0 [110/65] via 123.123.123.2, 02:39:10, Serial0/0
     144.144.0.0/32 is subnetted, 1 subnets
O       144.144.144.144 [110/2] via 14.14.14.4, 02:18:00, FastEthernet1/0
     11.0.0.0/24 is subnetted, 1 subnets
C       11.11.11.0 is directly connected, Loopback0
     123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       123.123.123.3/32 [110/64] via 123.123.123.3, 02:39:10, Serial0/0
O       123.123.123.2/32 [110/64] via 123.123.123.2, 02:39:10, Serial0/0
C       123.123.123.0/24 is directly connected, Serial0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.14.14.0 is directly connected, FastEthernet1/0
O*E2 0.0.0.0/0 [110/1] via 14.14.14.4, 02:18:00, FastEthernet1/0



R2:


R2#sh prot | e una|do  
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 123.123.123.2/24
Loopback0 is up, line protocol is up
  Internet address is 22.22.22.22/24


R2#sh run int s0/0
Building configuration...

Current configuration : 289 bytes
!
interface Serial0/0
 ip address 123.123.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 123.123.123.1 201 broadcast
 frame-relay map ip 123.123.123.2 201
 no frame-relay inverse-arp
end





R2#sh run | s r o
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 123.123.123.2 0.0.0.0 area 0



 R2#sh ip ro | b ^G
Gateway of last resort is 123.123.123.1 to network 0.0.0.0

     33.0.0.0/24 is subnetted, 1 subnets
O       33.33.33.0 [110/129] via 123.123.123.1, 02:43:09, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     144.144.0.0/32 is subnetted, 1 subnets
O IA    144.144.144.144 [110/66] via 123.123.123.1, 02:41:42, Serial0/0
     11.0.0.0/24 is subnetted, 1 subnets
O       11.11.11.0 [110/65] via 123.123.123.1, 02:43:09, Serial0/0
     123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       123.123.123.3/32 [110/128] via 123.123.123.1, 02:43:09, Serial0/0
O       123.123.123.1/32 [110/64] via 123.123.123.1, 02:43:09, Serial0/0
C       123.123.123.0/24 is directly connected, Serial0/0
     14.0.0.0/24 is subnetted, 1 subnets
O IA    14.14.14.0 [110/65] via 123.123.123.1, 02:43:09, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 123.123.123.1, 02:22:04, Serial0/0
 

R3:


R3#sh prot | e una|do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 123.123.123.3/24
Loopback0 is up, line protocol is up
  Internet address is 33.33.33.33/24


R3#sh run int s0/0
Building configuration...

Current configuration : 289 bytes
!
interface Serial0/0
 ip address 123.123.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 123.123.123.1 301 broadcast
 frame-relay map ip 123.123.123.3 301
 no frame-relay inverse-arp
end
 

 R3#sh run | s r o
 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 123.123.123.3 0.0.0.0 area 0


R3#sh ip ro | b ^G
Gateway of last resort is 123.123.123.1 to network 0.0.0.0

     33.0.0.0/24 is subnetted, 1 subnets
C       33.33.33.0 is directly connected, Loopback0
     22.0.0.0/24 is subnetted, 1 subnets
O       22.22.22.0 [110/129] via 123.123.123.1, 02:46:13, Serial0/0
     144.144.0.0/32 is subnetted, 1 subnets
O IA    144.144.144.144 [110/66] via 123.123.123.1, 02:44:36, Serial0/0
     11.0.0.0/24 is subnetted, 1 subnets
O       11.11.11.0 [110/65] via 123.123.123.1, 02:46:13, Serial0/0
     123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       123.123.123.2/32 [110/128] via 123.123.123.1, 02:46:13, Serial0/0
O       123.123.123.1/32 [110/64] via 123.123.123.1, 02:46:13, Serial0/0
C       123.123.123.0/24 is directly connected, Serial0/0
     14.0.0.0/24 is subnetted, 1 subnets
O IA    14.14.14.0 [110/65] via 123.123.123.1, 02:46:13, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 123.123.123.1, 02:24:58, Serial0/0




R4:


R4#sh prot | e una|do
Global values:
  Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
  Internet address is 14.14.14.4/24
FastEthernet1/0 is up, line protocol is up
  Internet address is 45.45.45.4/24
Loopback0 is up, line protocol is up
  Internet address is 44.44.44.44/24
Loopback1 is up, line protocol is up
  Internet address is 144.144.144.144/24


R4#sh run | s r r
router rip
 version 2
 network 44.0.0.0
 network 45.0.0.0
 no auto-summary




R4#sh run | s r o
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 14.14.14.4 0.0.0.0 area 1
 default-information originate always


  
R4#sh ip ro | b  ^G
Gateway of last resort is 45.45.45.5 to network 0.0.0.0

     155.155.0.0/24 is subnetted, 1 subnets
R       155.155.155.0 [120/1] via 45.45.45.5, 00:00:24, FastEthernet1/0
     33.0.0.0/24 is subnetted, 1 subnets
O IA    33.33.33.0 [110/66] via 14.14.14.1, 02:28:36, FastEthernet0/0
     22.0.0.0/24 is subnetted, 1 subnets
O IA    22.22.22.0 [110/66] via 14.14.14.1, 02:28:36, FastEthernet0/0
     144.144.0.0/24 is subnetted, 1 subnets
C       144.144.144.0 is directly connected, Loopback1
     11.0.0.0/24 is subnetted, 1 subnets
O IA    11.11.11.0 [110/2] via 14.14.14.1, 02:28:36, FastEthernet0/0
     123.0.0.0/32 is subnetted, 3 subnets
O IA    123.123.123.3 [110/65] via 14.14.14.1, 02:28:36, FastEthernet0/0
O IA    123.123.123.2 [110/65] via 14.14.14.1, 02:28:36, FastEthernet0/0
O IA    123.123.123.1 [110/1] via 14.14.14.1, 02:28:36, FastEthernet0/0
     44.0.0.0/24 is subnetted, 1 subnets
C       44.44.44.0 is directly connected, Loopback0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.14.14.0 is directly connected, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
C       45.45.45.0 is directly connected, FastEthernet1/0
R*   0.0.0.0/0 [120/1] via 45.45.45.5, 00:00:24, FastEthernet1/0



R5:


R5#sh prot | e una|do
Global values:
  Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
  Internet address is 45.45.45.5/24
FastEthernet1/0 is up, line protocol is up
  Internet address is 56.56.56.5/24
Loopback0 is up, line protocol is up
  Internet address is 55.55.55.55/24
Loopback1 is up, line protocol is up
  Internet address is 155.155.155.155/24


R5#sh run | i ip route
ip route 0.0.0.0 0.0.0.0 45.45.45.4
 

 R5#sh run | s r r
 router rip
 version 2
 network 45.0.0.0
 network 155.155.0.0
 default-information originate
 no auto-summary



R5#sh run | s r o    
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 56.56.56.5 0.0.0.0 area 2
 default-information originate



R5#sh ip ro | b ^G
Gateway of last resort is 45.45.45.4 to network 0.0.0.0

     155.155.0.0/24 is subnetted, 1 subnets
C       155.155.155.0 is directly connected, Loopback1
     55.0.0.0/24 is subnetted, 1 subnets
C       55.55.55.0 is directly connected, Loopback0
     66.0.0.0/24 is subnetted, 1 subnets
O       66.66.66.0 [110/2] via 56.56.56.6, 00:01:00, FastEthernet1/0
     56.0.0.0/24 is subnetted, 1 subnets
C       56.56.56.0 is directly connected, FastEthernet1/0
     44.0.0.0/24 is subnetted, 1 subnets
R       44.44.44.0 [120/1] via 45.45.45.4, 00:00:07, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
C       45.45.45.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 45.45.45.4

 

R6:


R6#sh prot | e una|do
Global values:
  Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
  Internet address is 56.56.56.6/24
Loopback0 is up, line protocol is up
  Internet address is 66.66.66.66/24


 R6#sh run | s r o
 router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 network 56.56.56.6 0.0.0.0 area 2



R6#sh ip ro | b ^G
Gateway of last resort is 56.56.56.5 to network 0.0.0.0

     55.0.0.0/24 is subnetted, 1 subnets
O       55.55.55.0 [110/2] via 56.56.56.5, 02:12:56, FastEthernet0/0
     66.0.0.0/24 is subnetted, 1 subnets
C       66.66.66.0 is directly connected, Loopback0
     56.0.0.0/24 is subnetted, 1 subnets
C       56.56.56.0 is directly connected, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 56.56.56.5, 02:03:20, FastEthernet0/0

Final Reachability Check using TCL:


tclsh
foreach address {
123.123.123.1
14.14.14.1
11.11.11.11
123.123.123.2
22.22.22.22
123.123.123.3
33.33.33.33
14.14.14.4
45.45.45.4
44.44.44.44
144.144.144.144
45.45.45.5
56.56.56.5
55.55.55.55
155.155.155.155
56.56.56.6
66.66.66.66
} {ping $address}



HTH...
Deepak Arora



2 comments:

Mahi said...

Hi Deepak !!

How are you doing!!

I just started to watch your blogs and seen the OSPF challenge and was labbing that scenario. Solution1 given by you do not seems to be correct as only static route was allowed but the route added on R5 is a default route. I have also seen the solution 2 & 3 which can be done in more easy way. i have commented on those solutions as well !!

A Network Artist said...

Technically a static default route is also considered as Static Route. Also believe it or not but PBR is technically also a form of static route only.

HTH...
Deepak Arora