Wednesday, February 27, 2013

Configuring VSS on Catalyst 4500 (From Guest Blogger Vijay Bhargav)







Prior Recommended Readings:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps9336/prod_qas0900aecd806ed74b.html

http://www.cisco.com/en/US/products/ps9336/prod_white_papers_list.html


Configuring VSS on 6500:

http://itknowledgeexchange.techtarget.com/network-engineering-journey/how-to-configure-vss/?goback=.gde_37265_member_214704760


Configuring VSS on 4500:

https://supportforums.cisco.com/docs/DOC-29472#_Some_key_point_to_be_remembered_for_Cisco_4500_VSS



HTH...
Deepak Arora
Evil CCIE
Virtual switching system (VSS) Configuration For Cisco 4500 series switches - See more at: https://supportforums.cisco.com/docs/DOC-29472#_Some_key_point_to_be_remembered_for_Cisco_4500_VSS

Tuesday, February 19, 2013

IS-IS Multitopology



Task Requirements:
+++++++++++++++

> Establish the connectivity within ISIS area as per Topology and Addressing. 
        Ensure All Routers are L2 Only routers.
> Ensure R5 Can Ping R1's Loopback0s IPv4 address as well as IPv6 address 
        with source as it's own loopback0. 
> Ensure IPv4/IPv6 traffic follows optimal path.


Initial Configurations
++++++++++++++++

R1
===


!
en
!
conf t
!
no ip do lo
!
no cdp run
!
ho R1
!
int lo0
 ip add 1.1.1.1 255.255.255.255
 ipv6 address 1:1:1:1::1/64
 exit
!
int f0/0
 ip add 12.0.0.1 255.255.255.0
 no sh
 exit
!
int f0/1
 ipv6 add 2001:13:13:13::1/64
 no sh
 exit
!
line con 0
 no exec-timeout
 logging sync
!
end
!


===========================================

R2
===

!
en
!
conf t
!
no ip do lo
!
no cdp run
!
ho R2
!
int lo0
 ip add 2.2.2.2 255.255.255.255
 exit
!
int f0/1
 ip add 12.0.0.2 255.255.255.0
 no sh
 exit
!
int f0/0
 ip add 25.0.0.2 255.255.255.0
 no sh
 exit
!
line con 0
 no exec-timeout
 logging sync
!
end
!

===================================
R3
===


!
en
!
conf t
!
no ip do lo
!
no cdp run
!
ho R3
!
int f0/1
 ipv6 address 2001:13:13:13::3/64
 no sh
 exit
!
int f0/0
 ipv6 address 2001:34:34:34::3/64
 no sh
 exit
!
line con 0
 no exec-timeout
 logging sync
 exit
!
end
!

===========================================
R4
===


!
en
!
conf t
!
no ip do lo
!
no cdp run
!
ho R4
!
int f0/1
 ipv6 add 2001:34:34:34::4/64
 no sh
 exit
!
int f0/0
 ipv6 add 2001:45:45:45::4/64
 no sh
 exit
!
line con 0
 logging sync
 exec-timeout 0 0
 exit
!
end
!

==============================
R5
===


!
en
!
conf t
!
no ip do lo
!
ho R5
!
no cdp run
!
!
int lo0
 ip add 5.5.5.5 255.255.255.255
 ipv6 add 5:5:5:5::5/64
 exit
!
int f0/0
 ip add 25.0.0.5 255.255.255.0
 no sh
 exit
!
int f0/1
 ipv6 add 2001:45:45:45::5/64
 no sh
 exit
!
line con 0
 no exec-timeout
 logging sync
 exit
!
end
!

=========================================================


Final Configurations
+++++++++++++++

R1
==

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ipv6 address 1:1:1:1::1/64
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:13:13:13::1/64
 ipv6 router isis 1
!
router isis 1
 net 49.0123.1111.1111.1111.00
 is-type level-2-only
 metric-style wide
 passive-interface Loopback0
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
!




R2
===

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 25.0.0.2 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 12.0.0.2 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
!
router isis 1
 net 49.0123.2222.2222.2222.00
 is-type level-2-only
 metric-style wide
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
!




R3
===

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:34:34:34::3/64
 ipv6 router isis 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:13:13:13::3/64
 ipv6 router isis 1
!
router isis 1
 net 49.0123.3333.3333.3333.00
 is-type level-2-only
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
!



R4
===

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:45:45:45::4/64
 ipv6 router isis 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:34:34:34::4/64
 ipv6 router isis 1
!
router isis 1
 net 49.0123.4444.4444.4444.00
 is-type level-2-only
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

!


R5
===

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip router isis 1
 ipv6 address 5:5:5:5::5/64
 ipv6 router isis 1
!
interface FastEthernet0/0
 ip address 25.0.0.5 255.255.255.0
 ip router isis 1
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:45:45:45::5/64
 ipv6 router isis 1
!
router isis 1
 net 49.0123.5555.5555.5555.00
 is-type level-2-only
 metric-style wide
 !
 address-family ipv6
  multi-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


HTH...
Deepak Arora
Evil CCIE

Tuesday, February 12, 2013

IS-IS Mock Lab - 14 Tasks Published With Video Solutions


IOS Details

 


Recommended Readings:  
2.> http://www.cisco.com/en/US/partner/tech/tk365/tk381/tsd_technology_support_sub-protocol_home.html

Initial Conifgurations
@@@@@@@@@@

R1
===

!
en
!
conf t
!
no ip do lo
!
ho R1
!
no cdp run
!
int lo0
 ip add 1.1.1.1 255.255.255.255
 exit
!
int s0/0
 encap frame
 no shut
 exit
!
int s0/0.12 point-to-point
 ip add 12.0.0.1 255.255.255.0
 no frame inv
 frame inter 102
 exit
!
int s0/0.13 multipoint
 ip add 13.0.0.1 255.255.255.0
 no frame inv
 frame map ip 13.0.0.3 103 b
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

######################################


R2
===

!
en
!
conf t
!
no ip do lo
!
ho R2
!
no cdp run
!
int lo0
 ip add 2.2.2.2 255.255.255.255
 exit
!
int s0/0
 enc frame
 no sh
 exit
!
int s0/0.21 point-to-point
 ip add 12.0.0.2 255.255.255.0
 no frame inv
 frame inter 201
 exit
!
int f0/0
 ip add 24.0.0.2 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

#######################################


R3
===

!
en
!
conf t
!
no ip do lo
!
ho R3
!
no cdp run
!
int lo0
 ip add 3.3.3.3 255.255.255.255
 exit
!
int s0/0
 ip add 13.0.0.3 255.255.255.0
 en frame
 no frame inv
 frame map ip 13.0.0.1 301 b

 frame map clns 301 b
 no sh
 exit
!
int s0/1
 ip add 37.0.0.3 255.255.255.0
 no sh
 exit
!
int s0/2
 ip add 38.0.0.3 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!


########################################



R4
===


!
en
!
conf t
!
no ip do lo
!
ho R4
!
no cdp run
!
int lo0
 ip add 4.4.4.4 255.255.255.255
 exit
!
int f0/0
 ip add 24.0.0.4 255.255.255.0
 no sh
 exit
!
int s0/0
 ip add 46.0.0.4 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

########################################



R5
===


!
en
!
conf t
!
ho R5
!
no ip do lo
!
no cdp run
!
int lo0
 ip add 5.5.5.5 255.255.255.255
 exit
!
int f0/0
 ip add 65.0.0.5 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!


########################################


R6
===

!
en
!
conf t
!
no ip do lo
!
ho R6
!
no cdp run
!
int lo0
 ip add 6.6.6.6 255.255.255.255
 exit
!
int s0/0
 ip add 46.0.0.6 255.255.255.0
 no sh
 exit
!
int f0/0
 ip add 65.0.0.6 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

#########################################

R7
===

!
en
!
conf t
!
no ip do lo
!
ho R7
!
no cdp run
!
int lo0
 ip add 7.7.7.7 255.255.255.255
 no sh
 exit
!
int s0/0
 ip add 37.0.0.7 255.255.255.0
 no sh
 exit
!
int f0/0
 ip add 150.0.0.7 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

########################################


R8
===


!
en
!
conf t
!
ho R8
!
no ip do lo
!
no cdp run
!
int lo0
 ip add 8.8.8.8 255.255.255.255
 exit
!
int s0/0
 ip add 38.0.0.8 255.255.255.0
 no sh
 exit
!
int f0/0
 ip add 150.0.0.8 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!

########################################



R9
===

!
en
!
conf t
!
ho R9
!
no ip do lo
!
no cdp run
!
int lo0
 ip add 9.9.9.9 255.255.255.255
 exit
!
int f0/0
 ip add 150.0.0.9 255.255.255.0
 no sh
 exit
!
line con 0
 logging syn
 no exec-time
 exit
!
end
!


%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%





TASKS
^^^^^^

1. Establish loopback to loopback connectivity between all Routers in all 3 AREAs 
     as per Diagram.
2. Create loopback on R9 - 99.99.99.99/32, Make sure R3 prefer R7 over R8 to 

     reach that network.Don't change metric. Also don't summarize the route.
3. Ensure you can see specific route for 1.1.1.1/32 into R9 Routing Table.
4. Configure Secure Authentication between R5 & R6 using password "cisco".
5. Configure basic Authentication between R4 & R6 using password "auth".
* 6. Area Authentication - Needs to be Updated
7. Ensure there is no DIS Election on network segment 65.0.0.0/24.
8. Ensure R4 is always elected as DIS on segment 24.0.0.0/24.
9. Ensure R7 is always elected as DIS on segment 150.0.0.0/24. You are not allowed to 

    change interface priority for this task.
10. Ensure that R3 always prefer path through R7 over R8 in order to reach

      prefix 9.9.9.9/32.
11. Create loopback199 on R9 with address 199.199.199.199/32. Ensure R3 always
       prefer path through R8 over R7 to reach this destination. But backup path should 

       be available all the time.
12. Ensure All Routers in future can support MPLS Traffic Engineering (TE).
13. Ensure R9 Sends Hello in every 30 sec and Dead interval = 4xHello Interval.
14. Ensure R5 Sends Hello packets out in every 200 ms.


Solutions
TASK 1 Solution
 

TASK 2 Solution

TASK 3 Solution


TASK 4 Solution


TASK 5 Solution


TASK 7 Solution


TASK 8 Solution
 



TASK 9 Solution

Task - 9  > 3.1 Correction - Highest System ID

TASK 10 Solution



                                                              TASK 11 Solution 


 TASK 12 Solution

TASK 13 Solution


TASK 14 Solution



HTH...
Deepak Arora
Evil CCIE