Tuesday, September 7, 2010

Frame-Relay Switching & Unnumbered Interfaces

So after staying away from my blog I am back again with some more exiting stuff for today.

As everyone know that New CCIE Ver 4 Lab consists many new topics. One topic among that all new exiting stuff is Frame-Relay Switching. I have already explained FR Switching in by previous blog post HERE

But that was all basic stuff. Now today we gonna add little more stuff over top of it.

The idea came into mind when one friend sent me a scenario and diagram asking about it's solution in my opinion. He was attempting one mock lab today. So I thought to bring that idea here for everyone.


Here is the quick diagram - Click on image for better view :)


Here were the quick requirements:


1. Use LMI type CISCO over FR-SW
2. On R1 & R3 LMI Autosense should be enabled
3. On R1 & R3 don't use any Static FR Mappings or Inverse ARP
4. Use PPP Over FR between R1 and R3
5. Take any IP Address from any available physical interface 
   as mentioned in diagram.
6. Keep In mind that in future you are supposed to run Multi-Link
    , so plan things accordingly at this initial stage. 


Cool...isn't it ?   :-)


What would be your solution ?


Here is mine:

Lets configure FR-SW first:

!        
frame-relay switching

!
FR-SW#sh run int s0/0
Building configuration...

Current configuration : 191 bytes
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 231 interface Serial0/1 233
end
!
FR-SW#
FR-SW#sh run int s0/1
Building configuration...

Current configuration : 191 bytes
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 233 interface Serial0/0 231
end
!
FR-SW#


Now lets hop on to R1 and configure it:

R1#sh run int multilink1
Building configuration...

Current configuration : 121 bytes
!
interface Multilink1
 ip unnumbered FastEthernet0/0
 no peer neighbor-route
 ppp multilink
 ppp multilink group 1
end

!
R1#sh run int Virtual-Template1
Building configuration...

Current configuration : 89 bytes
!
interface Virtual-Template1
 no ip address
 ppp multilink
 ppp multilink group 1
end

!
R1#sh run int s0/0
Building configuration...

Current configuration : 171 bytes
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay interface-dlci 231 ppp Virtual-Template1
 no frame-relay inverse-arp
end

!
R1#sh run int f0/0
Building configuration...

Current configuration : 89 bytes
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.0.0.0
 duplex auto
 speed auto
end

!
R1#sh run | s r o
router ospf 1
 log-adjacency-changes
 network 10.0.0.1 0.0.0.0 area 0

!

Now Lets hop on to R3:


R3#sh run int mu1
Building configuration...

Current configuration : 121 bytes
!
interface Multilink1
 ip unnumbered FastEthernet0/0
 no peer neighbor-route
 ppp multilink
 ppp multilink group 1
end

!
R3#sh run int Virtual-temp1
Building configuration...

Current configuration : 89 bytes
!
interface Virtual-Template1
 no ip address
 ppp multilink
 ppp multilink group 1
end

!
R3#sh run int s0/0
Building configuration...

Current configuration : 171 bytes
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay interface-dlci 233 ppp Virtual-Template1
 no frame-relay inverse-arp
end

!
R3#sh run int f0/0
Building configuration...

Current configuration : 89 bytes
!
interface FastEthernet0/0
 ip address 20.0.0.1 255.0.0.0
 duplex auto
 speed auto
end

!
R3#sh run | s r o
router ospf 1
 log-adjacency-changes
 network 20.0.0.1 0.0.0.0 area 0

!

Lets verify reach-ability from R1's Ethernet to R2's Ethernet interface since we disabled PPP peer neighbor route:


R1#ping 20.0.0.1 so f0/0 r 10

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.1
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 116/196/260 ms



Ping me on IM if you don't understand something just in case, because All I presented here was just verification and config I did without much theory details.


BTW... FR LMI Autosense feature is enabled by default in IOS 12.4T which is default in R&S Lab.

HTH....

Deepak Arora

1 comment:

Anonymous said...

If a need to use the endpoint-identified to form the multilink? how can I do?