R3#sh run | s mpls|FastEthernet0/0.34|FastEthernet0/0.36|Loopback33|router isis|Tunnel
mpls traffic-eng tunnels
mpls label protocol ldp
ip router isis
interface Loopback33
ip address 33.33.33.33 255.255.255.255
interface Tunnel319
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 19.19.19.19
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 2000
tunnel mpls traffic-eng path-option 1 explicit name TE
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 20.3.4.3 255.255.255.0
ip router isis
ipv6 address 2001:20:3:4::3/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.36
encapsulation dot1Q 36
ip address 20.3.6.3 255.255.255.0
ip router isis
ipv6 address 2001:20:3:6::3/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
router isis
net 11.0703.0000.0000.0000.3333.00
metric-style wide
!
address-family ipv6
multi-topology
exit-address-family
mpls ldp autoconfig level-2
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
ip route 199.199.199.199 255.255.255.255 Tunnel319
mpls ldp router-id Loopback0 force
ip route 199.199.199.199 255.255.255.255 Tunnel319
==================================================================================================
R4#sh run | s mpls|FastEthernet0/0.34|FastEthernet0/0.45|FastEthernet0/0.46|router isis
mpls traffic-eng tunnels
mpls label protocol ldp
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 20.3.4.4 255.255.255.0
ip router isis
ipv6 address 2001:20:3:4::4/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 20.4.5.4 255.255.255.0
ip router isis
ipv6 address 2001:20:4:5::4/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.46
encapsulation dot1Q 46
ip address 20.4.6.4 255.255.255.0
ip router isis
ipv6 address 2001:20:4:6::4/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
mpls ldp autoconfig level-2
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
mpls ldp router-id Loopback0 force
router isis
net 11.0744.0000.0000.0000.4444.00
metric-style wide
!
address-family ipv6
multi-topology
exit-address-family
mpls ldp autoconfig level-2
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
==================================================================================================
R5#sh run | s mpls|FastEthernet0/0.45|FastEthernet0/0.56|FastEthernet0/0.519|router isis
mpls traffic-eng tunnels
mpls label protocol ldp
ip router isis
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 20.4.5.5 255.255.255.0
ip router isis
ipv6 address 2001:20:4:5::5/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.56
encapsulation dot1Q 56
ip address 20.5.6.5 255.255.255.0
ip router isis
ipv6 address 2001:20:5:6::5/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.519
encapsulation dot1Q 519
ip address 20.5.19.5 255.255.255.0
ip router isis
router isis
net 11.0755.0000.0000.5555.00
metric-style wide
!
address-family ipv6
multi-topology
exit-address-family
mpls ldp autoconfig level-2
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
==================================================================================================
R6#sh run | s mpls|FastEthernet0/0.36|FastEthernet0/0.46|FastEthernet0/0.56|FastEthernet0/0.619|router isis
mpls traffic-eng tunnels
mpls label protocol ldp
ip router isis
ipv6 router isis
interface FastEthernet0/0.36
encapsulation dot1Q 36
ip address 20.3.6.6 255.255.255.0
ip router isis
ipv6 address 2001:20:3:6::6/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.46
encapsulation dot1Q 46
ip address 20.4.6.6 255.255.255.0
ip router isis
ipv6 address 2001:20:4:6::6/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.56
encapsulation dot1Q 56
ip address 20.5.6.6 255.255.255.0
ip router isis
ipv6 address 2001:20:5:6::6/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
interface FastEthernet0/0.619
encapsulation dot1Q 619
ip address 20.6.19.6 255.255.255.0
ip router isis
ipv6 address 2001:20:6:19::6/64
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 2000
router isis
net 11.0766.0000.0000.0066.6600
metric-style wide
!
address-family ipv6
multi-topology
exit-address-family
mpls ldp autoconfig level-2
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
mpls ldp router-id Loopback0 force
==================================================================================================
XR1
===
explicit-path name TE
index 1 next-address strict ipv4 unicast 20.5.19.5
index 2 next-address strict ipv4 unicast 20.4.5.4
index 3 next-address strict ipv4 unicast 20.3.4.3
!
interface tunnel-te193
ipv4 unnumbered Loopback0
signalled-bandwidth 2000
destination 3.3.3.3
path-option 1 explicit name TE
!
!
router static
address-family ipv4 unicast
33.33.33.33/32 tunnel-te193
!
!
router isis abcd
net 11.0719.0000.0000.1919.00
address-family ipv4 unicast
metric-style wide
mpls traffic-eng level-2-only
mpls traffic-eng router-id Loopback0
!
address-family ipv6 unicast
metric-style wide
!
interface Loopback0
circuit-type level-2-only
address-family ipv4 unicast
!
!
interface GigabitEthernet0/1/0/0.519
circuit-type level-2-only
address-family ipv4 unicast
!
!
interface GigabitEthernet0/1/0/0.619
circuit-type level-2-only
address-family ipv4 unicast
!
!
rsvp
interface GigabitEthernet0/1/0/0.519
bandwidth 2000
!
interface GigabitEthernet0/1/0/0.619
bandwidth 2000
!
!
mpls traffic-eng
interface GigabitEthernet0/1/0/0.519
!
interface GigabitEthernet0/1/0/0.619
!
!
mpls ldp
router-id 19.19.19.19
interface GigabitEthernet0/1/0/0.519
!
interface GigabitEthernet0/1/0/0.619
!
==================================================================================================
R3#traceroute 199.199.199.199 source lo33
Type escape sequence to abort.
Tracing the route to 199.199.199.199
1 20.3.6.6 [MPLS: Label 16 Exp 0] 4 msec 0 msec 4 msec
2 20.5.6.5 [MPLS: Label 16 Exp 0] 0 msec 4 msec 0 msec
3 20.5.19.19 4 msec * 4 msec
RP/0/0/CPU0:XR1#traceroute 33.33.33.33 so 199.199.199.199
Wed May 1 02:09:04.449 UTC
Type escape sequence to abort.
Tracing the route to 33.33.33.33
1 20.5.19.5 [MPLS: Label 27 Exp 0] 4 msec 4 msec 3 msec
2 20.4.5.4 [MPLS: Label 26 Exp 0] 4 msec 3 msec 3 msec
3 20.3.4.3 2 msec * 3 msec
HTH...
Deepak Arora
Evil CCIE
No comments:
Post a Comment