Wednesday, January 13, 2010

GRE Tunnel Across Frame-Relay Multipoint






Hmmm....may be not the one of the best diagram I have here these days....but using MS Paint those are easy to build...yet enough informative....and takes less time than Visio style of diagram.


Anyways...here is a quick challenge task....R1/R2/R3 are configured in Frame-Relay hub and spoke style of network using Physical Frame-relay Interfaces. Loopback 1 on all routers has been added for basic reach-ability using Static Routing. Now Challenge was to establigh connectivity from R2's Loop 2 to R3's Loop 2 interface through GRE tunnel. EIGRP is running over GRE tunnel and Loop 2 interfaces. So Using R1 I basically tried to simulate Service Provider Router which is connecting two branch office routers but Provider Shouldn't be able to see routing information of Branch offices LAN segments which I simulated here using Loopback 2 interfaces. So all set....lets hop on to config :)





R1#sh ip int b | e unassigned|down
Interface                  IP-Address            OK? Method Status                Protocol
Serial0/0                    10.0.0.1               YES manual up                    up
Loopback1                  100.100.100.100   YES manual up                    up

R1#sh run | s ip route
ip route 5.5.5.1 255.255.255.255 10.0.0.2
ip route 5.5.5.2 255.255.255.255 10.0.0.3
ip route 125.0.0.0 255.0.0.0 10.0.0.2
ip route 150.0.0.0 255.0.0.0 10.0.0.3

R1#sh run int s0/0
Building configuration...

Current configuration : 227 bytes
!
interface Serial0/0
 ip address 10.0.0.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.0.0.2 102 broadcast
 frame-relay map ip 10.0.0.3 103 broadcast
 no frame-relay inverse-arp
end

R2(config)#do sh ip int b | e unassigned|down
Interface                  IP-Address          OK? Method Status             Protocol
Serial0/0                  10.0.0.2              YES manual  up                    up
Loopback1               125.125.125.125   YES manual  up                    up
Loopback2               1.1.1.1                YES manual  up                    up
Tunnel1                   5.5.5.1                YES manual  up                    up

R2(config)#do sh run | s ip route
ip route 5.5.5.2 255.255.255.255 10.0.0.1
ip route 100.0.0.0 255.0.0.0 10.0.0.1
ip route 150.0.0.0 255.0.0.0 10.0.0.1

R2(config)#do sh run | s router
router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 5.5.5.1 0.0.0.0
 no auto-summary

R2(config)#do sh run int s0/0
Building configuration...

Current configuration : 217 bytes
!


interface Serial0/0
 ip address 10.0.0.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.0.0.1 201 broadcast
 frame-relay map ip 10.0.0.3 201
 no frame-relay inverse-arp
end

R2(config-if)#do sh run int tu 1
Building configuration...


Current configuration : 120 bytes
!
interface Tunnel1
 ip address 5.5.5.1 255.255.255.0
 tunnel source Loopback1
 tunnel destination 150.150.150.150
end

R3#sh ip int b | e unassigned|down


Interface                  IP-Address          OK? Method Status                Protocol
Serial0/0                  10.0.0.3               YES manual up                    up
Loopback1                150.150.150.150    YES manual up                    up
Loopback2                2.2.2.1                  YES manual up                    up
Tunnel1                    5.5.5.2                  YES manual up                    up

R3#sh run | s ip route
ip route 5.5.5.1 255.255.255.255 10.0.0.1
ip route 100.0.0.0 255.0.0.0 10.0.0.1
ip route 125.0.0.0 255.0.0.0 10.0.0.1

R3#sh run | s router
router eigrp 10
 network 2.2.2.1 0.0.0.0
 network 5.5.5.2 0.0.0.0
 auto-summary


R3#sh run int s0/0
Building configuration...

Current configuration : 217 bytes
!
interface Serial0/0


 ip address 10.0.0.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.0.0.1 301 broadcast
 frame-relay map ip 10.0.0.2 301
 no frame-relay inverse-arp
end

R3(config-if)#do sh run int tu1
Building configuration...

Current configuration : 120 bytes
!
interface Tunnel1
 ip address 5.5.5.2 255.255.255.0
 tunnel source Loopback1
 tunnel destination 125.125.125.125
end

Happy Studying.....

Best Regards,
Deepak Arora

No comments: