At-least I didn't....
So next step was to determine the subnet mask into Decimal format to see if it matches my network device configuration. So I quickly took the windows calculator and tried to conver ff000000 into binary. Though It took a min or two to figure out how many digits from Hex needs to be picked up for each decimal block. And the answer was "Two"
so finally I had answer that subnet mask was put by unix administrator was "255.0.0.0" where my vlan subnet configuration was configured for different subnet mask. So I quickly replied unix administrator suggesting to change the subnet mask to the correct one and of course that fixed the issue.
After that next morning I did some research on Subnet mask in Hex format and found that some old Unix box use to support it in that format only.
But one interesting thing I found was that our very own Cisco IOS also supports that format. And I was like :
Yes. So I quickly did some test and here are results:
R1#sh ver | i IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)
R1#sh ip int brief | e una|do
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 20.20.20.20 YES manual up up
FastEthernet0/1 30.30.30.30 YES manual up up
Loopback0 10.10.10.10 YES manual up up
R1#sh protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 20.20.20.20/8
FastEthernet0/1 is up, line protocol is up
Internet address is 30.30.30.30/16
Loopback0 is up, line protocol is up
Internet address is 10.10.10.10/30
R1#terminal ip netmask-format ?
bit-count Display netmask as number of significant bits
decimal Display netmask in dotted decimal
hexadecimal Display netmask in hexadecimal
R1#terminal ip netmask-format hexadecimal
R1#sh protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 20.20.20.20 0xFF000000
FastEthernet0/1 is up, line protocol is up
Internet address is 30.30.30.30 0xFFFF0000
Loopback0 is up, line protocol is up
Internet address is 10.10.10.10 0xFFFFFFFC
R1#sh run int f0/0
Building configuration...
Current configuration : 92 bytes
!
interface FastEthernet0/0
ip address 20.20.20.20 255.0.0.0
duplex auto
speed auto
end
R1#terminal ip netmask-format decimal
R1#sh protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 20.20.20.20 255.0.0.0
FastEthernet0/1 is up, line protocol is up
Internet address is 30.30.30.30 255.255.0.0
Loopback0 is up, line protocol is up
Internet address is 10.10.10.10 255.255.255.252
R1#sh run int f0/0
Building configuration...
Current configuration : 92 bytes
!
interface FastEthernet0/0
ip address 20.20.20.20 255.0.0.0
duplex auto
speed auto
end
R1#terminal ip netmask-format bit-count
R1#sh protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 20.20.20.20/8
FastEthernet0/1 is up, line protocol is up
Internet address is 30.30.30.30/16
Loopback0 is up, line protocol is up
Internet address is 10.10.10.10/30
R1#sh run int f0/0
Building configuration...
Current configuration : 92 bytes
!
interface FastEthernet0/0
ip address 20.20.20.20 255.0.0.0
duplex auto
speed auto
end
Few other interesting facts I found were :
> If you ever change the netmask format from global mode, it never shows up into the running config
R1#terminal ip netmask-format hexadecimal
R1#sh run | i terminal
R1#
> You can change the format for particular line (VTY Vs Aux Vs Con) And this time it will reflect into the running configuration.
R1(config)#line con 0
R1(config-line)#ip netmask-format ?
bit-count Display netmask as number of significant bits
decimal Display netmask in dotted decimal
hexadecimal Display netmask in hexadecimal
R1(config-line)#ip netmask-format hexadecimal
R1(config-line)#end
R1#sh run | b netmask
ip netmask-format hexadecimal
line aux 0
line vty 0 4
!
HTH...
Deepak Arora
Evil CCIE