Wednesday, August 4, 2010

MIB - Management Information Base (An Inside Look)


MIB
In the world of routers, network management is based on the concept of a Management Information Base (MIB), a database of manageable items. In a typical MIB, you will find the system name, IP routing tables, and counts of the packets handled by each protocol, as well as counters and statistics specific to the performance of QOS.

The most popular protocol in use to manipulate MIBs is SNMP. A second version of SNMP has been developed. SNMPv2 is part of the Internet Standard Network Management Framework version 2 and is accompanied by nearly a dozen attending documents. RFC 1441 introduces the entire framework. Version 1 MIB corresponds roughly to version 1 SNMP and is documented in RFC 1155. MIB-II, the most widely implemented MIB, is documented in RFC 1213. RFC 1902 discusses version 2 MIB structure.

The MIB model is quite powerful. SNMP is a quality protocol, and many MIBs have been written for QoS settings. The most used MIB when troubleshooting QoS-related issues is the class-based QoS MIB, which provides read access to QoS configurations. This MIB also provides QoS statistics information based on the modular QoS CLI, including information regarding class map and policy map parameters.

This class-based QoS MIB is actually two MIBs: CISCO-CLASS-BASED-QOS-MIB and CISCO-CLASS-BASED-QOS-CAPABILITY-MIB.
It is not the intention here to list all available MIBs. Apart from the sheer number of them, they are also subject to change and enhancement, quickly rendering the text obsolete.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use the Cisco MIB Locator found at the following website:


In case the Cisco MIB Locator does not support the MIB information that you need, you can obtain a list of supported MIBs and download them from the Cisco MIBs page at the following website:


HTH...
Deepak Arora

Tuesday, August 3, 2010

Frame-Relay Challenge 2 - Solve The Puzzle

So here I am with Another and little more challenging Frame-Relay Scenario/Challenge: I'll post the solution on Friday evening which gives you plenty of time ofcourse.



Task:
Configure the router in a Hub & Spoke manner using IP addressing and DLCI information given in above diagram.

R1 - This router should use DLCIs 102, 103 & 104 for it's connection to R2, R3 and R4 respectively. This router should be configured in a multipoint manner.

R2, R3 & R4 - DLCIs 201, 301 & 401 should be used by R2, R3 and R4 respectively for their Frame-Relay connection to R1.


Ensure that these routers have full reachability to every loopback interface, this should include their own interface too.

Restrictions - 1.) You are not allowed to user " frame-relay map ip ", and/or  static/dynamic routing to accomplish this task.

2.) None Of the routers should be configured with sub-interfaces/s.


HTH...
DEEPAK ARORA

Frame-Relay Challenge 1 - Solution

So the time has come when I am gonna reveal the solution for this post. I got lots of solution configs over my email. But without going further, go ahead and match your configs with my solution (Which I believe meets the requirements). In-case someone feels that my solution is not correct or something, please go ahead and send email with explanations.

Now talking back about the solution. First I would like to share my strategy about my approach to solve this FR puzzle. My idea here is to break the scenario in tiny parts and for this purpose I took a Piece of paper and made a chart to see what are restrictions and how to overcome those restrictions in best possible way.

So here is how my chart looked alike:




Now by looking at this chart you should have basic idea about how to solve this puzzle.


Here is a step by step config of each router.







So now at this point we have basic L2 connectivity to all other peer routers.


Now lets see if we can ping our own interfaces, which will accomplish the requirement of full reachability including reachability to self interfaces.


lets hop on to R3 and first ping peer routers to verify basic L2 connectivity:


So we can reach the peer routers but can't ping our own interface. "Debug Frame-Relay packet" gives us a great clue here that L3 to L2 resolution is not occurring for local interface. Here is a quick way to fix this:




Now by repeating same process i.e. putting map for local ip with local dlci, we can achieve full reachability over Router R1, R2 and R3.


But what about R4 ?


Lets hop on to R4 and see if it can ping it's own IP address without adding more config:




And magically R4 can ping it's own ip address without adding more config. But why is that?


Hmmm.... that's because it's a FR P2P sub-interface which is same as a back to back P2P connections between routers. It doesn't require any manual L3 to L2 resolution.


Now lets verify last part, if traffic destined from R2 towards R4 transit through R1:




And sure enough it is :-)

And there is one more FR challenge underway :-)


HTH....
Deepak Arora

Friday, July 30, 2010

Frame-Relay Challenge 1 - Solve The Puzzle

So welcome back everyone and here is the first puzzle which I am posting for blog followers today. Up-till now I was showing up various scenarios with explanation and required configs & other details.

But today I want to add some more fun here for you guys. So here is a great frame-relay challenge for you guys which I solved recently sent by one friend. And of-course this scenario got so much to teach you and test your frame-relay skills. To solve this scenario you would need to recall all frame relay basics. At-least that's what I feel honestly.

One last thing as surprise package is - the first guy who will post the correct solution as per requirements will get a surprise CCIE R&S preparation material from me in free. :-)

I'll wait till 5 PM IST Monday evening before I post the correct solution here. So good luck as you have plenty of time for such small but still interesting task to be solved & have a nice weekend ahead.

Here are the quick requirements with Detailed Diagram. 

1.> Configure a partially meshed Frame-Relay network between Router R1, R2, R3 & R4 Using DLCI information given in the diagram

2.> Don't use subinterfaces on R1, R2 & R3

3.> Use Sub-interface on .1 on R4 eg - s0/0.1

4.> Don't use any dynamic Frame-Relay mappings anywhere

5.> Don't use any Static Frame-Relay mappings on R4

6.> Traffic From R2 destined for R4 should transit R1

7.> All other traffic should take the most direct path through Frame-Relay network

Note:- No Extra Configs should be put unless otherwise specified, all router should have full reach-ability (including self interfaces), no redundant broadcast should be occurring on any of DLCIs.

For those who want to test this topology on GNS and are little new to Frame-Relay Switch  configurations over GNS. Here is a quick screen shot for you of  FR Switch Mappings:

And of course you can send me your solution directly through email at  - deepakarora.1984@gmail.com

And at last but not least....Don't just freak out in the middle while solving this :-)